Contact Support : +64 220 256 070

Aimvm
Blog

error updating cpanel : incompatble version of exim

Posted on: August 21, 2015

 

Cpanel requires updating so that new features will be operational which includes multiple major versions of cPanel & WHM, the update process upgrades your server to each intermediate version. The update process performs compatibility checks for each version prior to the upgrade to that version. If the process encounters blockers, it finishes on the most recent release of cPanel & WHM that is compatible with your system.

 

There are many reason for failure of cPanel update process.  The below mentioned is an example of cPanel update failure caused by incompatible version of exim.

error update cpanel : incompatble version of exim

Progressive Reset failed. This is usually due to an incompatible version of exim being installed

For all the exim related errors the file to check is /var/log/exim_mainlog

In my case I am getting the below error in exim_mainlog

Unable to write /etc/exim.conf: Permission denied at /usr/local/cpanel/scripts/buildeximconf line 77.
Progressive Reset failed. This is usually due to an incompatble version of exim being installed.

The only way to fix this error is to update the exim on server.

Follow the below mentioned steps.

1. Enter WHM at https://xxxx:2087/
2. Enter the Exim Configuration Editor:
(Service Configuration >> Exim Configuration Editor >> Advanced Configuration Editor)
3. Notate any custom changes you have made in the ACL section.
You may also which to make a copy of /etc/exim.conf.local
and /etc/exim.conf.localopts as it they your custom settings.
4. Click the ‘Reset ACL Config to Defaults’ button.
5. Reinstall your advanced custom settings.

 

Now update the cpanel again. This time there won’t be any errors related to exim.

 

 

Search Blog